Install sqlite3 gem

To install sqlite3 gem we need to install development package for ruby and sqlite3 it self because of the need to compile gem native extension.

On ubuntu/mint/debian do as follow :

apt-get install ruby-dev

apt-get install libsqlite3-dev

Dont forget to execute as root.

After that we can execute gem install sqlite3.

Thats all … Bye.

Happy chinesse new year 2570 !

Installing wxWidgets on Debian based linux

Debian based linux like ubuntu and linux mint can use these steps to install wxWidgets.

$ sudo apt-get install build-essential

If we do not have a C++ compiler yet, we install the build-essential package.

I think this is an meta package that install the actual packages for programming task.

$ sudo apt-get install libwxgtk3.0-dev

This installs the wxWidgets package.

To test it with minimal console application that emit some text we will create console.cpp and compile it.

#include <wx/wx.h>

int main(int argc, char **argv)
{
wxPuts(wxT(“A wxWidgets console application”));
}

Continue reading “Installing wxWidgets on Debian based linux”

Meld : compare merge

Ubuntu 18.04 LTS have an application that can be use by developer to compare files or folders called MELD.

FreeBSD also have it on its package collection. Just do pkg install meld.

Good night …